Supporting each other

Community forums

Welcome, Guest
Username: Password: Remember me
Questions on getting Xerte Toolkits installed on your server and questions about authentication and user logins.
  • Page:
  • 1
  • 2

TOPIC:

Blank page after new installation 1 month 1 week ago #8031

  • tom
  • tom's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 1143
  • Thank you received: 251
No need to reinstall. Just try to load the management.php file again, and see if you have errors in the log

Please Log in or Create an account to join the conversation.

Blank page after new installation 1 month 1 week ago #8032

  • simonbarne
  • simonbarne's Avatar Topic Author
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 23
  • Thank you received: 3
Thanks, I tried that and nothing was written to the log.

(I checked the log was getting error messages beforehand.)

Please Log in or Create an account to join the conversation.

Blank page after new installation 1 month 1 week ago #8033

  • tom
  • tom's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 1143
  • Thank you received: 251
Could you please try to set $development to true in the config.php of your Xerte installation (around line 43) and then try again?

Please Log in or Create an account to join the conversation.

Blank page after new installation 1 month 1 week ago #8034

  • simonbarne
  • simonbarne's Avatar Topic Author
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 23
  • Thank you received: 3
[06-Apr-2022 15:00:50 Europe/Berlin] PHP Fatal error: Uncaught Error: Class 'Xerte_Authentication_Abstract' not found in /usr/www/users/intoue/xerte/library/Xerte/Authentication/Db.php:34
Stack trace:
#0 /usr/www/users/intoue/xerte/library/autoloader.php(32): require_once()
#1 [internal function]: _xerte_autoloader('Xerte/Authentic...')
#2 /usr/www/users/intoue/xerte/library/Xerte/Authentication/Factory.php(48): spl_autoload_call('Xerte_Authentic...')
#3 /usr/www/users/intoue/xerte/management.php(177): Xerte_Authentication_Factory::create('Db')
#4 {main}
thrown in /usr/www/users/intoue/xerte/library/Xerte/Authentication/Db.php on line 34

Please Log in or Create an account to join the conversation.

Blank page after new installation 1 month 1 week ago #8035

  • tom
  • tom's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 1143
  • Thank you received: 251
Hmmm... That certainly is the cuase, but I have at the moment no clue what could cause this.

Basically it complains that it cannot find the file Xerte/Authentication/Abstract.php or that there is something wrong with it (wrong permissions).

What version of PHP are you using? I really do not understand. Any other errors in the log?
The following user(s) said Thank You: simonbarne

Please Log in or Create an account to join the conversation.

Last edit: by tom.

Blank page after new installation 1 month 1 week ago #8036

  • simonbarne
  • simonbarne's Avatar Topic Author
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 23
  • Thank you received: 3
Solved! Xerte/Authentication/Abstract.php was missing for some reason. I've uploaded it and can now log in.
Many thanks!

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
  • 2
Time to create page: 0.053 seconds
Copyright © 2022 The Xerte Project.
Xerte logo Apereo logo OSI Logo

Search