Supporting each other

Community forums

Welcome, Guest
Username: Password: Remember me
Questions on getting Xerte Toolkits installed on your server and questions about authentication and user logins.
  • Page:
  • 1
  • 2

TOPIC:

Blank page after new installation 4 months 6 days ago #8025

  • simonbarne
  • simonbarne's Avatar Topic Author
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 27
  • Thank you received: 3
I've just installed Xerte on a new public server. All seemed OK, but when I log in as admin at management.php, there's just a blank page.

On Chrome it says "This page isn’t working" and the site url "is currently unable to handle this request. HTTP ERROR 500".

Any ideas?

Please Log in or Create an account to join the conversation.

Blank page after new installation 4 months 5 days ago #8026

  • simonbarne
  • simonbarne's Avatar Topic Author
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 27
  • Thank you received: 3
I've just noticed the new database doesn't have config or configdetails tables, unlike the old database.

Please Log in or Create an account to join the conversation.

Blank page after new installation 4 months 5 days ago #8027

  • tom
  • tom's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 1180
  • Thank you received: 263
An error 500 indicates a PHP error. This could be a database related error, or a permission issue or a missing php extension.

Please try to see if you have an error in the apache/php error log.

Please Log in or Create an account to join the conversation.

Blank page after new installation 4 months 5 days ago #8028

  • simonbarne
  • simonbarne's Avatar Topic Author
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 27
  • Thank you received: 3
I was looking for this error log but can't find it. All I can see is HTTP Error Logs.

Please Log in or Create an account to join the conversation.

Blank page after new installation 4 months 5 days ago #8029

  • ronm
  • ronm's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 766
  • Thank you received: 221
Also just to be clear - if this was a clean new install then you will not have config or configdetails tables. These are not required and not the cause of your errors but will be created after running upgrade.php in future which is presumably why you have those tables in your "old" database. e.g. you have run upgrade on that previously.
HTH
Ron
Xerte developer & trainer
e-learning & m-learning consultant
mitchellmedia.co.uk | xerteacademy.com | learningapps.co.uk
Note: Support here is voluntary and meant for users to support each other.
Need direct commercial support with Xerte? mitchellmedia.co.uk/contact/
The following user(s) said Thank You: simonbarne

Please Log in or Create an account to join the conversation.

Blank page after new installation 4 months 5 days ago #8030

  • simonbarne
  • simonbarne's Avatar Topic Author
  • Offline
  • Junior Member
  • Junior Member
  • Posts: 27
  • Thank you received: 3
The host (Hetzner) says:

PHP error log

To log PHP errors, you need to first add an empty log file (e.g. over FTP). After that, add the following lines to your .htaccess file to activate the error log:

php_flag log_errors on
php_value error_log /usr/home/«login»/php.log

(In this example, the file is php.log and is in the home folder of the account. You need to replace «login» with the FTP user name of the account.)

docs.hetzner.com/konsoleh/account-manage...n/php-configuration/

Having done this, should I reinstall Xerte and see what happens?

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
  • 2
Time to create page: 0.050 seconds
Copyright © 2022 The Xerte Project.
Xerte logo Apereo logo OSI Logo

Search