Supporting each other

Community forums

Welcome, Guest
Username: Password: Remember me

TOPIC: Acces module: No HTTP Referer

Acces module: No HTTP Referer 1 year 2 weeks ago #5325

  • ronm
  • ronm's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 528
  • Thank you received: 128
I've tested this now via Moodle 3.3x and Moodle 3.5x and Xerte 3.6 and Xerte X and I can't reproduce this not working. Actually I could reproduce it when my xerte was local in my xampp and http not https so I'm wondering if that's the issue here?

Fay/JaapJan are both your Moodle and Xerte https or is perhaps one https and the other http? It might well be that Moodle no longer passes referrer details to http destinations or perhaps if Moodle is http rather than https. Otherwise I can't explain why it isn't working for you.

HTH
Ron
Xerte developer & trainer
e-learning & m-learning consultant
mitchellmedia.co.uk
xerteacademy.com
learningapps.co.uk

Please Log in or Create an account to join the conversation.

Acces module: No HTTP Referer 1 year 2 weeks ago #5327

  • JaapJan
  • JaapJan's Avatar Topic Author
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 114
  • Thank you received: 1
Hello Michell

I realise that my xerte installation is just a simple http URL. I will try to see what happens when I make it https. Moodle is indeed a https domain. I keep in touch

By the way:I tested it in 3.6 and X
Holy cow!

Please Log in or Create an account to join the conversation.

Last edit: by JaapJan.

Acces module: No HTTP Referer 1 year 1 week ago #5336

  • Fay
  • Fay's Avatar
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 158
  • Thank you received: 49
It is working here after all - I've just heard back from the person who was having issues & it's fine. Sorry to have confused matters - it was a message passed to me second hand & since our Moodle had recently updated I thought it likely to be related to that.

Please Log in or Create an account to join the conversation.

Acces module: No HTTP Referer 1 year 1 week ago #5338

  • JaapJan
  • JaapJan's Avatar Topic Author
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 114
  • Thank you received: 1
Fay

it is not working in my installation. Do you use https for Moodle AND Xerte? I have only https installed on Moodle.

JaapJan
Holy cow!

Please Log in or Create an account to join the conversation.

Acces module: No HTTP Referer 1 year 1 week ago #5339

  • tom
  • tom's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 862
  • Thank you received: 158
@JaapJan, can we have a look together at some point?
The following user(s) said Thank You: JaapJan

Please Log in or Create an account to join the conversation.

Acces module: No HTTP Referer 1 year 1 week ago #5341

  • Fay
  • Fay's Avatar
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 158
  • Thank you received: 49
Yes, we use https on Moodle & Xerte

Please Log in or Create an account to join the conversation.

Moderators: alimcn
Time to create page: 0.054 seconds
Copyright © 2019 The Xerte Project.
Xerte logo Apereo logo OSI Logo

Search