Supporting each other

Community forums

Welcome, Guest
Username: Password: Remember me
Questions on getting Xerte Toolkits installed on your server and questions about authentication and user logins.
  • Page:
  • 1

TOPIC:

xerte issue after failed tsugi install due to php v8.1 1 week 20 hours ago #8265

  • chandrika
  • chandrika's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 9
  • Thank you received: 0
I had a working install of XERTE on my shared server space. I used the TSUGI install script inside XERTE and received the error message that TSUGI install failed due to PHP v8.1 being incompatible. On checking it appears that TSUGI currently requires PHP v8 max.

At this point I lost access to xerte, everytime I tried to access mysite.co.uk/xerte I get error message "database setup failed". So I uninstalled XERTE, downgraded my PHP version to V8 and did a fresh install. The fresh install was successful, I can see the DB has been created, the file structure is there, but I just keep getting the error message "database setup failed" which appears to be left over from the failed TSUGI install...

I have contacted my server support, but thought I would check here too to see if anyone has any ideas, or has run into this.

Please Log in or Create an account to join the conversation.

xerte issue after failed tsugi install due to php v8.1 1 week 18 hours ago #8266

  • chandrika
  • chandrika's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 9
  • Thank you received: 0
I have now managed to install XERTE by rolling back the PHP version.

I am wondering what the max php version is at this time, that XERTE is compatible with?

Please Log in or Create an account to join the conversation.

xerte issue after failed tsugi install due to php v8.1 1 week 18 hours ago #8267

  • tom
  • tom's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 1180
  • Thank you received: 263
Xerte itself is not so picky. It works on PHP 5.6 and higher up to PHP 8.1. It is best tested with 7.2 and 7.4.

Tsugiis pickier and support 7.4 or 8.0 (as far as I know, it is a different open source project that we use)
The following user(s) said Thank You: chandrika

Please Log in or Create an account to join the conversation.

Last edit: by tom.
  • Page:
  • 1
Time to create page: 0.047 seconds
Copyright © 2022 The Xerte Project.
Xerte logo Apereo logo OSI Logo

Search