Supporting each other

Community forums

Welcome, Guest
Username: Password: Remember me
Questions on getting Xerte Toolkits installed on your server and questions about authentication and user logins.
  • Page:
  • 1

TOPIC: Problems with non-standard naming / SQL

Problems with non-standard naming / SQL 7 months 6 days ago #5678

  • therapynottingham
  • therapynottingham's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 2
  • Thank you received: 0
Hi
I'm trying to install Xerte in a shared hosting environment, which dictates how database names are created and which include hyphens. Mostly this doesn't cause too many issues, but I'm running in to issues installing Xerte. Im getting to:

Creating MySQL Database Failed!
Your Xerte Online Toolkits database has not been created! Please investigate the error messages and return to the previous page by pressing the button below!

Failed to execute query line 89 page2.php


And that is only if I hard code the basic.sql to include the `database-name` (with the additional ` ` 's).
But the DROP TABLE IF command is still failing (I also added in the $query so I could see where it failed). If I run the basic.SQL directly (within phpMyAdmin) then it all executes without error. How can I get past this to continue with the install?

Thanks (I hope)

Justin

Please Log in or Create an account to join the conversation.

Problems with non-standard naming / SQL 7 months 6 days ago #5679

  • tom
  • tom's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 869
  • Thank you received: 162
I have no idea why the drop tables are still failing, because these do include the ` characters.

But as the tables are not present anyway, you might consider removing or commenting out the drop tables for now, to be able to continue.

I'll investigate why it's not working later.

Please Log in or Create an account to join the conversation.

Problems with non-standard naming / SQL 7 months 6 days ago #5680

  • therapynottingham
  • therapynottingham's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 2
  • Thank you received: 0
I had the same idea after posting - but the CREATE TABLE fails as well. Maybe it's an issue with the username (which is also mandated to include hyphens)?
Is there a way to bypass this stage completely (because I can actually successfully execute the SQL in phpMyAdmin) ?

Please Log in or Create an account to join the conversation.

Problems with non-standard naming / SQL 7 months 6 days ago #5681

  • tom
  • tom's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 869
  • Thank you received: 162
You're moving into tricky territory. If the installation later doesn't work it will be difficult to make sure why that is.

If you're willing to continue, you can comment out lines 73-98 of setup/page2.php and add the following line in stead of that block (right after line 98):
$success = true;

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Time to create page: 0.051 seconds
Copyright © 2019 The Xerte Project.
Xerte logo Apereo logo OSI Logo

Search