Supporting each other

Community forums

Welcome, Guest
Username: Password: Remember me
Questions on getting Xerte Toolkits installed on your server and questions about authentication and user logins.
  • Page:
  • 1

TOPIC: Upgrade installation

Upgrade installation 7 months 5 days ago #5638

  • jtoomey
  • jtoomey's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0
Hi I'm upgrading from version 2 to X and I've followed the clean install instructions -
I've removed all files expect those listed
moved in the new files from the Xerte X download
ran the upgrade.php page

Now when trying to load the homepage I get just get a blank screen with the following PHP error
Fatal error: Class 'Xerte_Validate_FileExtension' not found in /mnt/webdata1/webs/eletoolkit.exeter.ac.uk/docs/plugins/file_uploading-extension-check.php on line 87

I think I'm missing some plugins but where do I get them from, or does anyone know where else I might have gone wrong?

Cheers
Jon

Please Log in or Create an account to join the conversation.

Upgrade installation 7 months 5 days ago #5639

  • ronm
  • ronm's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 528
  • Thank you received: 128
Hi
Did upgrade.php run fine and display confirmation messages?

What version of PHP are you using?

If your install was v2 is it on an old server where perhaps PHP components are missing? Ses xot.xerte.org.uk/play.php?template_id=81#page11 e.g.
Requires :
PHP v5.1.2 or later*
Apache or some other web server that is setup to execute PHP.
Write permission to USER-FILES
MySQL/MariaDB
*Extension needed include MySQL/PDO, zLib, SimpleXML, xml and LDAP (if you are using for LDAP authentication)

HTH
Ron
Xerte developer & trainer
e-learning & m-learning consultant
mitchellmedia.co.uk
xerteacademy.com
learningapps.co.uk
The following user(s) said Thank You: jtoomey

Please Log in or Create an account to join the conversation.

Upgrade installation 7 months 5 days ago #5640

  • tom
  • tom's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 862
  • Thank you received: 158
It can find the plugin itself, however it comapains that the class 'Xerte_Validate_FileExtension' cannot be found.

That class is defined in library/Xerte/Validate/FileExtension.php and should have been included from config.php using library/autoloader.php

Please Log in or Create an account to join the conversation.

Upgrade installation 7 months 4 days ago #5641

  • jtoomey
  • jtoomey's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 9
  • Thank you received: 0

Tom Reijnders wrote: It can find the plugin itself, however it comapains that the class 'Xerte_Validate_FileExtension' cannot be found.

That class is defined in library/Xerte/Validate/FileExtension.php and should have been included from config.php using library/autoloader.php


that's the one! thank you. Those files weren't present in the old version of Xerte so i added them from the download.

Seems to be working now! thank you for your help

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Time to create page: 0.049 seconds
Copyright © 2019 The Xerte Project.
Xerte logo Apereo logo OSI Logo

Search