Supporting each other

Community forums

Welcome, Guest
Username: Password: Remember me
Questions on getting Xerte Toolkits installed on your server and questions about authentication and user logins.
  • Page:
  • 1

TOPIC: Increase maximum file size?

Increase maximum file size? 4 years 2 months ago #4681

  • helenmd
  • helenmd's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 77
  • Thank you received: 4
I'm testing XOT 3.5 on our development server at the moment, and whenever I try to upload a video, I get a message saying "Upload Error. Data exceeds the maximum allowed size".

I'm sure I've asked this question before but I can't find the answer. Where in Xerte is this parameter set?

Many thanks in advance

Helen

Please Log in or Create an account to join the conversation.

Increase maximum file size? 4 years 2 months ago #4683

  • tom
  • tom's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 1092
  • Thank you received: 234
It's not a xerte setting, it's a php server setting.

If I remember correctly you have an install maintined by an ICT department. Correct? If so, ask them to increase the upload limit.
The following user(s) said Thank You: helenmd, SetaJackson

Please Log in or Create an account to join the conversation.

Increase maximum file size? 4 years 2 months ago #4684

  • helenmd
  • helenmd's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 77
  • Thank you received: 4
Thanks Tom, much appreciated!

Please Log in or Create an account to join the conversation.

Increase maximum file size? 3 years 7 months ago #5072

  • tsalyers
  • tsalyers's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 16
  • Thank you received: 0
Replying to this because I just ran into this recently myself, and in case anyone has the same problem...the relevant setting is in php.ini, and it's called upload_max_filesize. By default it's set to two megabytes (2M), which is a bit low for media files these days.

(Your php.ini location may vary. For me it's in /etc.)

Please Log in or Create an account to join the conversation.

Last edit: by tsalyers.

Increase maximum file size? 3 years 7 months ago #5073

  • ronm
  • ronm's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 709
  • Thank you received: 198
Hi
just to add you may also need to increase post_max_size too which generally needs to be larger than upload_max_filesize see php.net/manual/en/ini.core.php#ini.post-max-size

HTH
Ron
Xerte developer & trainer
e-learning & m-learning consultant
mitchellmedia.co.uk | xerteacademy.com | learningapps.co.uk
Note: Support here is voluntary and meant for users to support each other.
Need direct commercial support with Xerte? mitchellmedia.co.uk/contact/
The following user(s) said Thank You: tsalyers

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Time to create page: 0.049 seconds
Copyright © 2021 The Xerte Project.
Xerte logo Apereo logo OSI Logo

Search