Supporting each other

Community forums

Welcome, Guest
Username: Password: Remember me
The place for more technical questions for those who want to create new pagetypes or bespoke functionality.
  • Page:
  • 1

TOPIC: Drag and drop: match

Drag and drop: match 3 months 1 week ago #6732

  • Alan
  • Alan's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 15
  • Thank you received: 0
I've created an image, added three hotspot sections onto it and enabled the three corresponding elements to drag into the image.
When this object is set to 'Match', upon clicking 'Check' it will spit out the objects, saying 'try again'.

I have checked, by hovering over the hotspots and when an object is placed into it, it appears to iterate over to the next one.
i.e., Object1 -> Box1, then Box1 expects Object2...Even if it doesn't exist.

Has anyone encountered this, should be easy to replicate.

Please Log in or Create an account to join the conversation.

Drag and drop: match 3 months 1 week ago #6752

  • jjs
  • jjs's Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 377
  • Thank you received: 62
Hi,

What version are you running? (open /version.txt on xerte website root)

Drag and drop works fine for me in the github version but it may have been patched recently - the thing that i'm curious about is that I do not have a Check button, only submit:



Regards,

John
Attachments:
The following user(s) said Thank You: Alan

Please Log in or Create an account to join the conversation.

Drag and drop: match 3 months 1 week ago #6755

  • Alan
  • Alan's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 15
  • Thank you received: 0
Hi,

Thanks for the response - I have only just (genuinely, within the hour of posting) resolved this issue (mostly)

I have the Github version now, which I didn't before and the drag and drop is now working - Strange that it is bugged in the Xerte site download however.
I too have only the Submit button - in both versions

There is a bit of a bug, if you submit and continue and then go back, all of the hotspots jump to the top-left of the image

Thanks very much

Please Log in or Create an account to join the conversation.

Drag and drop: match 3 months 2 days ago #6769

  • Alan
  • Alan's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 15
  • Thank you received: 0
I might have made it seem like this issue was resolved for me - But, unfortunately the client version still has this bug.
Does anyone have an idea on how to go about fixing this?

Just to state clearly:
The version acquired from the official Xerte page has the bug that I have stated previously.
The version acquired from Github does not have this bug and works fine.
Is there a way I could investigate into fixing this? I'm not sure where to start - I imagine it's logical (PHP or JQuery)

Thanks in advance, much appreciated

Please Log in or Create an account to join the conversation.

Drag and drop: match 3 months 2 days ago #6770

  • jjs
  • jjs's Avatar
  • Offline
  • Moderator
  • Moderator
  • Posts: 377
  • Thank you received: 62
Hi Alan,

The Github one has been worked on since the last release which is why the problem you identified is fixed in that one. We are working on fixing the return to page issue you mention and should have a new page available by the weekend or early next week.

Regards,

John
The following user(s) said Thank You: Alan

Please Log in or Create an account to join the conversation.

Drag and drop: match 3 months 2 days ago #6771

  • Alan
  • Alan's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 15
  • Thank you received: 0
Hi John,

I see, thanks very much - makes sense - that works well for me :)

Thanks very much,

Alan

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Moderators: jjs
Time to create page: 0.130 seconds
Copyright © 2020 The Xerte Project.
Xerte logo Apereo logo OSI Logo

Search