Supporting each other

Community forums

Welcome, Guest
Username: Password: Remember me
Report any technical problems you discover and discuss solutions.
  • Page:
  • 1

TOPIC:

Personal Installation - URL not working 1 week 5 days ago #9119

  • sp812
  • sp812's Avatar Topic Author
  • Offline
  • New Member
  • New Member
  • Posts: 1
  • Thank you received: 0
Hey all,

I’ve been looking into installing Xerte locally to test it for our institution, and running into a few issues.

I’ve been following the Xerte Toolkits Installation Guide from the Xerte downloads area, and followed its instructions to install the xampp server, set Apache and MySQL to run, and extract the Xerte files. However, I then get to this “Then start a web browser, and then visit this address (I've added spaces in, as I am not allowed to post external urls as a new user): http:// localhost /xertetoolkits /setup/” – and whatever I try, can’t seem to get that url to work.

I’ve attached some screenshots below showing what I’ve found, which include the location of the xerte files, the xampp server settings, and the 'Not Found' issue.

Would you have any idea what I’m doing wrong? I also noticed the installation guide is 11 years out of date – is there a newer one available perhaps?

Thanks very much :)

Sam

Please Log in or Create an account to join the conversation.

Personal Installation - URL not working 1 week 5 days ago #9120

  • ronm
  • ronm's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 824
  • Thank you received: 251
Hi
So you’ve put the Xerte files inside htdocs in a folder named xertetoolkits correct?
If you visit http://localhost/ what do you see? You should see the xampp homepage which also includes a link to phpmyadmin.
If you visit phpmyadmin was a database created for xertetoolkits including various tables?
If yes check the paths in the site_details table are correct.
If you look in the xertetoolkits folder was a file named database.php created and does it contain the correct details for the xertetoolkits database and credentials?
I don’t see any attached screenshots?
The install guide is old and probably contains some older screenshots but it worked when it was created and is still mostly valid now.
Depending on what authentication method you chose during setup when you visit http://localhost/xertetoolkits you should either see the Xerte workspace as guest or a login screen if you chose db. The fact that it is redirecting to /setup typically means the connection to the database isn’t working.
HTH
Ron
Xerte developer & trainer
e-learning & m-learning consultant
mitchellmedia.co.uk | xerteacademy.com | learningapps.co.uk
Note: Support here is voluntary and meant for users to support each other.
Need direct commercial support with Xerte? mitchellmedia.co.uk/contact/
The following user(s) said Thank You: sp812

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Moderators: ronmjultenJohnSmith
Time to create page: 0.076 seconds
Copyright © 2024 The Xerte Project.
Xerte logo Apereo logo OSI Logo

Search