Supporting each other

Community forums

Welcome, Guest
Username: Password: Remember me
Report any technical problems you discover and discuss solutions.
  • Page:
  • 1
  • 2

TOPIC:

Open standalone page in lightbox not working in SCORM 7 months 5 days ago #7727

  • ymoore
  • ymoore's Avatar Topic Author
  • Offline
  • Senior Member
  • Senior Member
  • Posts: 71
  • Thank you received: 4
Hi All

Still struggling on with SCORM ... any help appreciated. I have a Xerte object that has a standalone page that should open in a lightbox. It works fine when viewing the Xerte project URL but once it's added to Moodle as a SCORM package the link no longer works (literally nothing happens when you click the link). Is this expected behaviour or a bug? (Tried with SCORM 2004 on Moodle 3.9).

Thanks again.
Yvonne

Please Log in or Create an account to join the conversation.

Open standalone page in lightbox not working in SCORM 7 months 5 days ago #7728

  • Fay
  • Fay's Avatar
  • Offline
  • Elite Member
  • Elite Member
  • Posts: 212
  • Thank you received: 73
Hi Yvonne
Thanks for letting us know about this - it's a bug. I've just tried it myself and get the same problem as you. I'll have a look into it and fix asap

Thanks
Fay
The following user(s) said Thank You: ymoore

Please Log in or Create an account to join the conversation.

Open standalone page in lightbox not working in SCORM 4 months 1 week ago #7872

  • ymoore
  • ymoore's Avatar Topic Author
  • Offline
  • Senior Member
  • Senior Member
  • Posts: 71
  • Thank you received: 4
Hi

We're currently testing version 3.10 before upgrading in a few weeks. I've re-tested a project exported as SCORM both types) and added to Moodle. When viewing the SCORM project in Moodle the lightbox content now opens, but only accurately on the first visit. Any subsequent visit seems to populate the lightbox with a different page from the project. Any ideas how to fix this?

Best wishes
Yvonne

Please Log in or Create an account to join the conversation.

Open standalone page in lightbox not working in SCORM 3 months 3 weeks ago #7911

  • A511197
  • A511197's Avatar
  • Offline
  • Premium Member
  • Premium Member
  • Posts: 128
  • Thank you received: 10
Hi Yvonne,
This might be related to my issue I posted this morning:https://www.xerte.org.uk/index.php/en/forum/bugs-and-issues/2807-media-lesson-stand-alone-page-bug-v3-10#7910
It's not a SCORM package but uses the Media Lesson page and a stand-alone page to display a lightbox image.

bw,
Alison
If you can use Lego, you can use Xerte

Please Log in or Create an account to join the conversation.

Open standalone page in lightbox not working in SCORM 3 months 3 weeks ago #7927

  • Fay
  • Fay's Avatar
  • Offline
  • Elite Member
  • Elite Member
  • Posts: 212
  • Thank you received: 73
Yvonne - when the project is viewed normally (not as SCORM) does the standalone page consistently open the correct page? Is this only an issue when in Moodle as SCORM?

Please Log in or Create an account to join the conversation.

Open standalone page in lightbox not working in SCORM 3 months 3 weeks ago #7929

  • ymoore
  • ymoore's Avatar Topic Author
  • Offline
  • Senior Member
  • Senior Member
  • Posts: 71
  • Thank you received: 4
It works fine viewing it as a Xerte project - I can go back and forth through the project and the stand-alone page consistently shows the correct content. However, in SCORM it displays correctly the first time, but if I go back and forth, any subsequent viewing shows a different page (in my example it goes from displaying the standalone page content to displaying the 'stop tracking' page content).

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
  • 2
Moderators: ronmjultenjjs
Time to create page: 0.046 seconds
Copyright © 2022 The Xerte Project.
Xerte logo Apereo logo OSI Logo

Search