Supporting each other

Community forums

Welcome, Guest
Username: Password: Remember me
Report any technical problems you discover and discuss solutions.
  • Page:
  • 1

TOPIC: Not able to create content after install

Not able to create content after install 5 months 4 days ago #7383

  • redlawn
  • redlawn's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 7
  • Thank you received: 0
I am trying to use xerte 3.9 on Centos 8, using apache and mariadb. The install goes through fine, I have set up LDAP and can log in.

CentOS Linux release 8.3.2011
httpd.x86_64 2.4.37-30.module_el8.3.0+561+97fdbbcc
php.x86_64 7.2.24-1.module_el8.2.0+313+b04d0a66
mariadb.x86_64 3:10.3.28-1.module_el8.3.0+757+d382997d

When I try and create a folder does nothing. I put a name in and press create and nothing happens, the create folder dialogue remains. The same happens when I try to create a project from a Project Template.

I have checked the permissions on the xerte folder and the web server has write access, I have disabled SELinux too.

I have a working 3.8 using LAMPP but I want to move away from using that so that I can maintain the apache and PHP security updates.

Please Log in or Create an account to join the conversation.

Not able to create content after install 5 months 4 days ago #7384

  • ronm
  • ronm's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 705
  • Thank you received: 196
Hi
looking at those details I think you are trying to install and use Xerte 3.9 on PHP 8x which will not work. You'll either need to switch to PHP 7x or wait for the official Xerte 3.10 release (due soon) which is compatible with PHP 8x.
HTH
Ron
Xerte developer & trainer
e-learning & m-learning consultant
mitchellmedia.co.uk | xerteacademy.com | learningapps.co.uk
Note: Support here is voluntary and meant for users to support each other.
Need direct commercial support with Xerte? mitchellmedia.co.uk/contact/
The following user(s) said Thank You: redlawn

Please Log in or Create an account to join the conversation.

Not able to create content after install 5 months 3 days ago #7389

  • redlawn
  • redlawn's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 7
  • Thank you received: 0
We are running 7.2.24:

~]# php --version
PHP 7.2.24 (cli) (built: Oct 22 2019 08:28:36) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies

Please Log in or Create an account to join the conversation.

Not able to create content after install 5 months 3 days ago #7391

  • tom
  • tom's Avatar
  • Away
  • Administrator
  • Administrator
  • Posts: 1085
  • Thank you received: 232
If there is a common issue, it can be caused by a missing PHP extension. Please verify the Apache / PHP error log for errors. You can change the value of $development (around line 46 in config.php) to true to get more verbose messages.

Having said that:

- Folder creation. Folders exist only in the database. Please verify if there are any javascript errors in the web browsers console (F12 on most modern browsers).

- As you stated, to be able to create projects, the permission need to be set correct. For each project a folder should be created inside the USER-FILES folder. Is this the case?

Please Log in or Create an account to join the conversation.

Not able to create content after install 5 months 3 days ago #7392

  • ronm
  • ronm's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 705
  • Thank you received: 196
Sorry I saw your post and quickly replied and I mis-read the details. But for anyone else reading this in future the point still stands it's only Xerte 3.10 and later that works on PHP 8x.

So does your installation work with authentication set to guest or db?
With authentication set to ldap and then you login is your user account created in the Xerte database? When you try to create a project is a project folder created where the parent folder contains id-username-parenttemplatename? e.g. 33-redlawn-Nottingham?

A few other things to do/check:
set $development=true; in config.php and then check the Xerte debug log.
Check the Apache error logs.
Check that the system requirements and in particular the PHP extensions are met xot.xerte.org.uk/play.php?template_id=81#systemrequirements

HTH
Ron
Xerte developer & trainer
e-learning & m-learning consultant
mitchellmedia.co.uk | xerteacademy.com | learningapps.co.uk
Note: Support here is voluntary and meant for users to support each other.
Need direct commercial support with Xerte? mitchellmedia.co.uk/contact/

Please Log in or Create an account to join the conversation.

Not able to create content after install 1 month 1 day ago #7677

  • redlawn
  • redlawn's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 7
  • Thank you received: 0
I found the issue a while back and should have posted back. I needed to add php-json and this fixed it.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Moderators: ronmjultenjjs
Time to create page: 0.050 seconds
Copyright © 2021 The Xerte Project.
Xerte logo Apereo logo OSI Logo

Search