Supporting each other

Community forums

Welcome, Guest
Username: Password: Remember me
Report any technical problems you discover and discuss solutions.
  • Page:
  • 1

TOPIC: Blank page upon creation of new content

Blank page upon creation of new content 1 year 5 months ago #6635

  • guidicini
  • guidicini's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 12
  • Thank you received: 0
Hello and thank you in advance to anyone reading my message.

I have the following problem:
- XOT38 just freshly installed (even though with a trick due to the lack of support of my ICT department: I installed it locally and then transferred all the files anb database with the supposed proper configurations to work on server)
- XOT38 starts and logs in and i can reach both management.php and the authoring interface

When I create an object in the authoring interface, though, the object is create but the editing window that pops up is blank: it doesn't show the usual options to create and edit elements. See the attached screenshot.

Is there anyone who can suggest me what to check to fix this issue?

Thank you very much in advance.

Fabrizio
Attachments:

Please Log in or Create an account to join the conversation.

Last edit: by guidicini.

Blank page upon creation of new content 1 year 5 months ago #6637

  • ronm
  • ronm's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 709
  • Thank you received: 198
Hi
so you've moved a local install (database and files) to an online server? What did you change on the online server after the move of the database and files?
Typically you would need to:
change various values in the sitedetails table like the url and paths.
ensure that permissions on various directories are correct
ensure that the server requirements are in place on the server see xot.xerte.org.uk/play.php?template_id=81#systemrequirements
check the error logs for an indication of what might be wrong
HTH
Ron
Xerte developer & trainer
e-learning & m-learning consultant
mitchellmedia.co.uk | xerteacademy.com | learningapps.co.uk
Note: Support here is voluntary and meant for users to support each other.
Need direct commercial support with Xerte? mitchellmedia.co.uk/contact/
The following user(s) said Thank You: guidicini

Please Log in or Create an account to join the conversation.

Blank page upon creation of new content 1 year 5 months ago #6638

  • guidicini
  • guidicini's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 12
  • Thank you received: 0
Hello Ron,

and thank you so much for the prompt reply.
Yes that's correct, that's what I did. I moved database and files on the server after having installed them locally.
Before moving all the items on the server I changed the file database.php to reflect the correct database connection and I changed the .sql file to reflect the new url of the site.
Please find attached ca screenshot of the sitedetails table if i missed any change to be done.

Permissions on the directories should be ok because my ICT department have told me that all the perimssions on our web space are almost free unless we change them.

PHP version is 7.0.33
Apache is set to use php (in fact we have other php applications already installed and running)
Is the database table engine MariaDB a mandatory requirement? If so may this affect things they way i showed you in my first attachment?
The MySQL installation of my ICT department gives all tables the InnoDB engine.
I am not sure if I can change it on the server.

Thank you a lot!

Fabrizio
Attachments:

Please Log in or Create an account to join the conversation.

Last edit: by guidicini.

Blank page upon creation of new content 1 year 5 months ago #6639

  • tom
  • tom's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 1092
  • Thank you received: 234
You missed two fields:

import_path and root_file_path

Of these two, the latter is causing your problem.
The following user(s) said Thank You: guidicini

Please Log in or Create an account to join the conversation.

Blank page upon creation of new content 1 year 5 months ago #6642

  • guidicini
  • guidicini's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 12
  • Thank you received: 0
Hello Tom,

sorry for the time replying and thank you!!!
I made some tests with your tip.
On one side you're right... I'm getting old ;-) and i missed those two settings.
On the other side, though, I have tried many ways to set them up but the issue is still present.
Any other tip to fix this issue?

Thanks a lot.

Fabrizo
Attachments:

Please Log in or Create an account to join the conversation.

Blank page upon creation of new content 1 year 5 months ago #6643

  • guidicini
  • guidicini's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 12
  • Thank you received: 0
By the way, I have tried to install the application directly on server (which i'd prefer), but that didn't work (i got an error message of "Failed to execute query line 89 page2.php" which i couldn't fix even following the tips found here

dedicated thread

on this forum).
This error wasn't given during the local install and so i thought to perform this last one and then move everything on line. Changing what I had.
to change.
Attachments:

Please Log in or Create an account to join the conversation.

Last edit: by guidicini.
  • Page:
  • 1
Moderators: ronmjultenjjs
Time to create page: 0.056 seconds
Copyright © 2021 The Xerte Project.
Xerte logo Apereo logo OSI Logo

Search