Supporting each other

Community forums

Welcome, Guest
Username: Password: Remember me
Report any technical problems you discover and discuss solutions.

TOPIC: xApi not working anymore

xApi not working anymore 2 months 4 days ago #5925

  • viragom
  • viragom's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 29
  • Thank you received: 0
installed the xapi_[roxy.php from the zip and run a LO

results from header:
Headers: Array
(
[Host] => [mydomain]
[Content-Length] => 1086
[sec-fetch-mode] => cors
[origin] => [myhttpsdomain]
[User-Agent] => Mozilla/5.0 (Windows NT 6.2; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.132 Safari/537.36 OPR/63.0.3368.71
[Content-Type] => application/json
[x-experience-api-version] => 1.0.1
[Authorization] => Basic dG9tOjEyMzQ=
[dnt] => 1
[Accept] => */*
[sec-fetch-site] => same-origin
[Referer] => https://[mydomain]/xertetoolkits/xapi_launch.php?template_id=45&group=havo4
[Accept-Encoding] => gzip, deflate, br
[Accept-Language] => nl-NL,nl;q=0.9,en-US;q=0.8,en;q=0.7
[Cookie] => PHPSESSID=j0kbc36jn9ui4hh264o6an6022
)

2019-09-07 12:09:21 /[mydomain]/public_html/xertetoolkits/xapi_proxy.php400 and then the rest of the debug messsage

Please Log in or Create an account to join the conversation.

Last edit: by viragom.

xApi not working anymore 2 months 4 days ago #5926

  • tom
  • tom's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 869
  • Thank you received: 162
That's odd...

The case of the experiance spi header is changed. Normally it is:
X-Experience-API-Version

I added that to the headers that need to be handled:

File Attachment:

File Name: xapi_proxy...9-07.zip
File Size:5 KB
Attachments:

Please Log in or Create an account to join the conversation.

xApi not working anymore 2 months 4 days ago #5927

  • viragom
  • viragom's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 29
  • Thank you received: 0
BINGO!!! That's it!!

Now there are statements in both Watersged and Scorm Cloud!!!!
(now i can look for more strange things.... ;-))))

BIG THANKS!!!

Please Log in or Create an account to join the conversation.

xApi not working anymore 2 months 3 days ago #5928

  • tom
  • tom's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 869
  • Thank you received: 162
It's still very weird that you have that header in lowercase. That header is created by a javascrit file, that should be the same for me and you.

Weird.

Please Log in or Create an account to join the conversation.

xApi not working anymore 2 months 3 days ago #5929

  • tom
  • tom's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 869
  • Thank you received: 162
I'll make sure that this version of xapy_proxy.php ends up in the next release.

Please Log in or Create an account to join the conversation.

Moderators: jultenjjs
Time to create page: 0.057 seconds
Copyright © 2019 The Xerte Project.
Xerte logo Apereo logo OSI Logo

Search