Supporting each other

Community forums

Welcome, Guest
Username: Password: Remember me
Report any technical problems you discover and discuss solutions.
  • Page:
  • 1

TOPIC: Offline Zip Not Working

Offline Zip Not Working 3 years 7 months ago #5055

  • engmex
  • engmex's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 7
  • Thank you received: 0
Hello, I've created a course, but when I export it as an offline Zip it doesn't work. I open the index.htm file in my Browser and it just displays a totally blank page. However, if I export a deployment zip it works fine, and appears to work offline too. Is there any reason I should use the offline package over the deployment package for offline use? And, if so what's the problem with the offline package not displaying the content. Additionally, there remains an error in all both the offline and deployment zip files:
testing: common_html5/mediaelement/DO NOT CHANGE THESE FILES. USE -src- FOLDER.txt
error: invalid compressed data to inflate
Which, means I need to unzip, remove the rouge files, and then rezip before distribution. I've mentioned this error in a previous post, but nobody seems interested. Am I alone with these errors?

Please Log in or Create an account to join the conversation.

Offline Zip Not Working 3 years 7 months ago #5056

  • tom
  • tom's Avatar
  • Offline
  • Administrator
  • Administrator
  • Posts: 1092
  • Thank you received: 234
I am going to fix the zip error

I am fixing the off-line zip

It depends on the browser whther the archive zip is working, because most browsers refuse to load dynamic data from a local drive for security reasons.

Please Log in or Create an account to join the conversation.

Offline Zip Not Working 3 years 7 months ago #5057

  • engmex
  • engmex's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 7
  • Thank you received: 0
Thanks!

Please Log in or Create an account to join the conversation.

Offline Zip Not Working 1 year 5 months ago #6619

  • islitech
  • islitech's Avatar
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 20
  • Thank you received: 0
I had a similar issue with deployment zips exported from a hosted Xerte installation. Apologies for dredging up an old thread, and I think these issues are fixed in more recent Xerte versions, but I'm posting what I found for information in case anyone else needs to fix this manually on an older installation.
Symptoms: Projects exported as deployment zips could not be fully extracted as 3 files in the zip caused errors:
  • common_html5\mediaelement\DO NOT CHANGE THESE FILES. USER -src- FOLDER.txt
  • themes\Nottingham\highcontrast\highcontrast.js
  • themes\Nottingham\blackonyellow\blackonyellow.js
I noticed that all of these files were empty (0KB in size). Comparing similar js files in other themes, they were small but had some data.

Solution: I found the corresponding files on the server:
  • ...\modules\xerte\parent_templates\Nottingham\common_html5\mediaelement\DO NOT CHANGE THESE FILES. USER -src- FOLDER.txt
  • ...\themes\Nottingham\highcontrast\highcontrast.js
  • ...\themes\Nottingham\blackonyellow\blackonyellow.js
I added some data to these files (a single space to the txt file, a small commented out line in the js files) and saved. Now they have a small but nonzero filesize.
Re-exported the deployment zip files and they will now extract fine with no errors. :)

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Moderators: ronmjultenjjs
Time to create page: 0.046 seconds
Copyright © 2021 The Xerte Project.
Xerte logo Apereo logo OSI Logo

Search