Supporting each other

Community forums

Welcome, Guest
Username: Password: Remember me
The place for more technical questions for those who want to create new pagetypes or bespoke functionality.
  • Page:
  • 1

TOPIC: Navigation menu

Navigation menu 8 months 1 week ago #6220

  • DKeus
  • DKeus's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 4
  • Thank you received: 1
Hello everyone,

I've recently started using the Xerte bootstrap to build pages for a school. I love the way it looks and works but did get some feedback from the educational institution I work for. My question: Can I somehow highlight the part of the vertical navigation menu on the left side of the page where the user currently is currently positioned? Or to put it in different words, can the highlighted part in blue (see picture) scroll with the user to show what subject is being looked at?

Thanks in advance,

David
Attachments:

Please Inloggen or Create an account to join the conversation.

Navigation menu 7 months 4 weeks ago #6245

  • drlara
  • drlara's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 15
  • Thank you received: 9
Hi, it looks like what you're asking is the default behaviour (see screenshot).
By looking at your screenshot, it seems that you didn't include the "titles" and I noticed that without titles, then it won't work.
You can add blank spaces as title but it can't be blank, otherwise, it doesn't work.
Attachments:
The following user(s) said Thank You: DKeus

Please Inloggen or Create an account to join the conversation.

Navigation menu 7 months 3 weeks ago #6257

  • DKeus
  • DKeus's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 4
  • Thank you received: 1
Thank you so much, that is exactly what I needed to know! I will try it out right away.

Please Inloggen or Create an account to join the conversation.

Navigation menu 7 months 3 weeks ago #6258

  • DKeus
  • DKeus's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 4
  • Thank you received: 1
Hi,
I followed your advice and still run into the same problem. I have attached a screenshot of the bootstrap. I have tried all possible combinations of titles and blank spaces: showing the title with blank spaces (multiple different numbers of spaces) and not showing a title but entering blanks or characters in the title field. It seemed to work some random times but then stopped working again for unknown reasons. I can't seem to pinpoint the source of the problem.

I even noticed that the Sample Xerte bootstrap on xot.xerte.org.uk (sorry can't post the link as a new user) has the same issue.

Can you tell me what I'm doing wrong?

Thanks in advance :)
The following user(s) said Thank You: drlara

Please Inloggen or Create an account to join the conversation.

Navigation menu 7 months 3 weeks ago #6259

  • drlara
  • drlara's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 15
  • Thank you received: 9
Hi. I'm not really sure what the problem could be... I'm using the latest update, the one that was released three months ago, on November 21, 2019.
You're right that in the Bootstrap sample they have in their website, the navigation is not working in the way you want it either. But perhaps it was created before Nov 21 and it might not be using the latest update.
I created a quick bootstrap project using their sample and the navigation seems to be working properly (it's changing as I scroll down within the content, as shown in the attached animated gif)
Here is the link to the project, copy and paste it into a new window: csumb.space/xert/play.php?template_id=2
Best luck!
Attachments:
The following user(s) said Thank You: DKeus

Please Inloggen or Create an account to join the conversation.

Last edit: by drlara. Reason: Image wasn't attached

Navigation menu 7 months 3 weeks ago #6266

  • DKeus
  • DKeus's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 4
  • Thank you received: 1
Thanks for your answer.

I found out something interesting. Upon opening your link I found that the scrolling didn't work either even though you showed it worked in your animated gif. I tried opening the link in Firefox and Edge (I was using Chrome) and it worked in those! That might be the root of the problem. I will investigate and get back to it if you are interested.

Please Inloggen or Create an account to join the conversation.

  • Page:
  • 1
Moderators: jjs
Time to create page: 0.050 seconds
Copyright © 2020 The Xerte Project.
Xerte logo Apereo logo OSI Logo

Search