Supporting each other

Community forums

Welcome, Guest
Username: Password: Remember me
Report any technical problems you discover and discuss solutions.
  • Page:
  • 1
  • 2

TOPIC: Problems adding/managing groups.

Problems adding/managing groups. 2 weeks 3 days ago #6646

  • piair
  • piair's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 7
  • Thank you received: 0
Hi everyone,

I could not find a solution for this one, maybe someone here on the forum knows:
I'm running XoT 3.85 (github release) in Docker. The database was originally created using 3.8, I did run /upgrade.php on it. If I re-run upgrade.php it states:
Current database version - 25
Database is up to date, nothing to do
In the management.php interface, I have no problems editing categories or courses.

However, de groupings page is empty:

I tried adding new groupings, but they don't get added/displayed here.
I see no errors in the browser, no console messages.
The groupings are also not displayed while editing a course:


The database does contain the default groupings. If I view the table grouping with PHPmyadmin, I get:


I want to add/use the grouping mechanism in combination with XAPI. This works without a problem for category values that I add (they get added to the statements) but I also want to use the grouping as a more fine grained way of grouping parts of a learning object.

What am I missing?
Attachments:

Please Inloggen or Create an account to join the conversation.

Problems adding/managing groups. 2 weeks 3 days ago #6648

  • tom
  • tom's Avatar
  • Online
  • Administrator
  • Administrator
  • Posts: 964
  • Thank you received: 193
Weird. Obviously the database is correct, and the query is really simple.

Could you please check if you have an error in the webserver logs? If not, could you please set $development to true on line 43 of config.php and retry. Afterwards, check the debug.log file in the error_logs folder.
The following user(s) said Thank You: piair

Please Inloggen or Create an account to join the conversation.

FIXED Problems adding/managing groups. 2 weeks 2 days ago #6649

  • piair
  • piair's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 7
  • Thank you received: 0
Ah, of course, forgot about that.

Enabling $development = true first increased the problems.

To begin with, there was a problem with the permissions of the error_logs folder. Probably my bad, all the folders in xerteonlinetoolkits that I linked as a volume in Docker had admin:users as owner. I fixed that by attaching as root to the container and:
cd xerteonlinetoolkits
chown -R www-data:www-data error_logs
chmod -R g+w error_logs
With that fixed, the browser showed a number of PHP errors:
Deprecated: Array and string offset access syntax with curly braces is deprecated
and
Warning: strpos(): Empty needle
errors in functions.php
(and some headers / session related things, but they were fixed by fixing the ones above).
It may have to do with me using PHP 7.4 (the deprecation one). Anyway, I fixed those and then was able to see a grouping related error:
Warning: Invalid argument supplied for foreach() in /var/www/html/xerteonlinetoolkits/website_code/php/management/management_library.php on line 61
In itself not so helpful, but debug.log showed that it did not like the SQL statement around the word grouping. I do not use database prefixes, if you do you probably won't have a problem there.
I fixed it the way I know that phpMyadmin does: add ` ` around the table name (including the optional prefix).
I had to change that in management_library.php, new_grouping.php, remove_grouping.php to fix the management.php part
I had to fix it in modules/xerte/edithtml.php to get it to work in the editor.

I forked the 3.8.5 code, made the changes in the fork and created a pull request for the changes. If I try to link directly to the pull request, the forum doesn't like my reply.

Leaving $development = true still showed some problems while opening the more complex courses that I imported from Deltion (not with the small ones that I created myself), causing the editor not to open. But the appear to more template related and not grouping related and the went away when I disabled development, so for now I am going to ignore those.

Please Inloggen or Create an account to join the conversation.

Last edit: by piair. Reason: The forum didn't accept my reply. Apparently I cannot link to the fork on github in my reply. If I do, it won't accept the reply.

NOT FIXED? Problems adding/managing groups. 2 weeks 2 days ago #6650

  • piair
  • piair's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 7
  • Thank you received: 0
Ehm, might have been too quick to declare "FIXED".
I still don't see the grouping in XAPI. I see parent, I see category, but nothing that points to the grouping that I attached.
Debug shows really cool info about the LTI handshaking and info going on, some high level XAPI info, but nothing that points to a possible location for an SQL statement related to the grouping table and XAPI.

Please Inloggen or Create an account to join the conversation.

NOT FIXED? Problems adding/managing groups. 2 weeks 2 days ago #6651

  • tom
  • tom's Avatar
  • Online
  • Administrator
  • Administrator
  • Posts: 964
  • Thank you received: 193
It's working for me...


The value is set in the editor/wizard of the learning object, and ends up in the data.xml in in the USER-FILES/.../ folder of your LO.

That's passed to the xapi tracking code of Xerte, and added to the xAPI record.
Attachments:

Please Inloggen or Create an account to join the conversation.

NOT FIXED? Problems adding/managing groups. 2 weeks 2 days ago #6652

  • tom
  • tom's Avatar
  • Online
  • Administrator
  • Administrator
  • Posts: 964
  • Thank you received: 193
Please note that the grouping is set on the actual interactivities.So for a quiz, thee will be records for the quiz, and for each question. The grouping is added to the question statements.

Please Inloggen or Create an account to join the conversation.

Last edit: by tom.
  • Page:
  • 1
  • 2
Moderators: jultenjjs
Time to create page: 5.231 seconds
Copyright © 2020 The Xerte Project.
Xerte logo Apereo logo OSI Logo

Search