Welcome, Guest
Username: Password: Remember me
Report any technical problems you discover and discuss solutions.

TOPIC: Logout Button not working

Logout Button not working 8 months 21 hours ago #5216

  • Helen Davies
  • Helen Davies's Avatar
  • Offline
  • Senior Boarder
  • Posts: 66
  • Thank you received: 3
Hi everyone,

Here in Swansea we are using Xerte v3.5. A colleague has reported that when you click the logout button, this doesn't work. I've tried and am consistently able to replicate this.

I've tried in Chrome, Firefox and Edge, and have deleted cache etc in each of the browsers to no avail.

Can anyone help?

Thanks

Helen
The administrator has disabled public write access.

Logout Button not working 8 months 21 hours ago #5217

  • Ron Mitchell
  • Ron Mitchell's Avatar
  • Offline
  • Administrator
  • Posts: 500
  • Thank you received: 120
Hi Helen
what authentication method is your installation using?
has anyone done any customisation to the authentication code?
This isn't a known bug and I just tested a 3.5 install which is using ldap and logout works fine as I would expect.
Sorry that doesn't really help but it isn't a 3.5 bug.
If you press F12, view the console and click logout do you see any errors?
Whoever looks after you server should be able to tell by looking at the error logs.
HTH
Ron
Xerte developer & trainer
e-learning & m-learning consultant
mitchellmedia.co.uk
xerteacademy.com
learningapps.co.uk
The administrator has disabled public write access.
The following user(s) said Thank You: Helen Davies

Logout Button not working 8 months 20 hours ago #5218

  • Helen Davies
  • Helen Davies's Avatar
  • Offline
  • Senior Boarder
  • Posts: 66
  • Thank you received: 3
Hi Ron,

Thanks for replying so quickly! We are authenticating to the database at the moment.

I know our tech guys are trying to get LDAP authentication to work but have been having issues - My colleague Ross posted about this issue last week I believe.

I'll go back and find out if this is what is causing the issue.

Thanks for the tip about the F12 check... I'll do that now.

Thanks again

Helen
The administrator has disabled public write access.

Logout Button not working 4 months 2 weeks ago #5437

  • Ross Keeling
  • Ross Keeling's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 1
Hi,

We're getting an error 500 and I cannot see why. This is the information I get from the console output:

VM245:1 POST xerte.swansea.ac.uk/website_code/php/logout.php 500 (Internal Server Error)
(anonymous) @ VM245:1
logout @ VM267 logout.js:123
onclick @ (index):106

When I look through the error logs, I only see a POST log with pretty much the same info:

POST /website_code/php/logout.php - 443 - [MyIP] Mozilla/5.0+(Windows+NT+10.0;+Win64;+x64)+AppleWebKit/537.36+(KHTML,+like+Gecko)+Chrome/70.0.3538.77+Safari/537.36 xerte.swansea.ac.uk/ 500 0 0 31

Has anyone experienced this sort of issue previously?

Many thanks,

Ross
The administrator has disabled public write access.
Moderators: Julian Tenney, John Smith
Time to create page: 0.234 seconds
Powered by Kunena Forum

Donate

Sponsor us

The Xerte Community is a volunteer-based organization. Please help us to continue that!