Welcome, Guest
Username: Password: Remember me
Questions on getting Xerte Toolkits installed on your server and questions about authentication and user logins.

TOPIC: LDAP Settings (new user)

LDAP Settings (new user) 4 years 1 month ago #2551

  • lee eardley
  • lee eardley's Avatar
  • Offline
  • Junior Boarder
  • Posts: 23
Ok, So I have been tasked with getting out Xerte system working here at Lincoln College. ( bearing in mind it hasnt worked for over a year and no one who is currently here has ever set it up, including myself)

I have managed to get the software installed v 2.1 and hosted and accessible at xerte.lincolncollege.ac.uk

I can get to the management.php and have configured as much as possible from the installation notes and also looking through the web for pointers.

I have managed to test that its working via setting up to authenticate via the DB and all is fine.

This would be the way we would use it if there were only a good handful of users but now found out we need to be using LDAP..... This is where the issues have come..

Attached is my LDAP screen shot of the settings I have put in, I have made sure that the locations are correct in AD and got a Senior IT Tech to have a quick look over also.

The settings in Auth_config.php are set to LDAP as well.

Any advice would be appreciated as we need to get this up and running as a matter of urgency.

Lee
The administrator has disabled public write access.

LDAP Settings (new user) 4 years 1 month ago #2552

  • Tom Reijnders
  • Tom Reijnders's Avatar
  • Offline
  • Administrator
  • Posts: 805
  • Thank you received: 154
Hello,

Well, you've come this far, I'll do my best to help you finish it.
Would you be so kind as to set $deveop to true, check the location of the debug.log file, so it is in a location where the system is allowed to write, in config.php around line 26?

Please try to do a login, and look at the debug.log file.

If you can, please send me the part of a login session, (after making sure there are no items in the log file you don't want to share, like login name and passwords)

If you want, you can send the log file to me by PM, in stead of posting here (reijnders at tor dot nl)
The administrator has disabled public write access.

LDAP Settings (new user) 4 years 1 month ago #2554

  • lee eardley
  • lee eardley's Avatar
  • Offline
  • Junior Boarder
  • Posts: 23
Good Morning,
Thanks for the reply

I have made the changes as requested and this is all I got in the debug.log
(I double checked that auth_config.php is set to LDAP

2015-02-04 09:45:19 C:\Inetpub\xertetoolkits\website_code\php\database_library.php139Running : SELECT * FROM sitedetails
2015-02-04 09:45:19 C:\Inetpub\xertetoolkits\library\Xerte\Authentication\Ldap.php57Running : SELECT * FROM ldap

Not sure if this shows much
The administrator has disabled public write access.

LDAP Settings (new user) 4 years 1 month ago #2556

  • Tom Reijnders
  • Tom Reijnders's Avatar
  • Offline
  • Administrator
  • Posts: 805
  • Thank you received: 154
Hmm.. let me have a look to get you a version with some more debugging information. Might take me a day.
The administrator has disabled public write access.
The following user(s) said Thank You: lee eardley

LDAP Settings (new user) 4 years 1 month ago #2602

  • Joe
  • Joe's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 1
I'm having the same issue and after setting debug to true my debug.log shows exactly the same error. Did the op get this sorted?
The administrator has disabled public write access.

LDAP Settings (new user) 4 years 1 month ago #2603

  • lee eardley
  • lee eardley's Avatar
  • Offline
  • Junior Boarder
  • Posts: 23
I have not heard anything back on this yet, If I do I will let you know.
The administrator has disabled public write access.
Time to create page: 0.243 seconds
Powered by Kunena Forum

Donate

Sponsor us

The Xerte Community is a volunteer-based organization. Please help us to continue that!